Algorithme : Exercices Corrigés Boucles Et Structure Alternative

EXERCICES_BOUCLES _ ALTERNATIVE

Algorithme : Exercices Corrigés Boucles Et Structure Alternative
Exercices Corrigés Boucles Et Structure Alternative

Exercices Corrigés Boucles Et Structure

Alternative

Exercice 1 :

Ecrire un algorithme qui demande d'entrer un nombre compris entre 1 et 3 jusqu'à ce que la réponse convienne

Solution :

Algo ex1

Var

x :entier 

Début

Répéter

                Ecrire’’ donner un nombre’’

                Lire x

Jusqu’à x>=1 et x<=3

                Ecrire ‘’valeur dans le bon intervalle’’

Fin

Exercice 2 :

Ecrire un algorithme qui demande d'entrer un nombre compris entre 10 et 20 jusqu'à ce que la réponse convienne. En cas de nombre supérieur à 20, on fera apparaitre un message '' plus petit '', et inversement si le nombre supérieur à 10, on fera apparaitre un message `` plus grand ''.

Solution :

Algo ex2

Var

x :entier 

Début

Ecrire’’ donner un nombre’’

Lire x

Tant que x<10 ou x>20 faire

                                Si x<10 alors

                                                Ecrire ’’ plus grand !’’

                                Si non

                                                Ecrire ’’ plus petit !’’

                                Fin si

Fin Tant que

Fin

Exercice 3 :

Ecrire un algorithme qui demande d'entrer un nombre de départ et en suit une affiche les dix nombres suivants. Par exemple si utilisateur entre 10 le programme affiche les nombres de 11 à 20  

Solution :

Algo ex3

Var

x :entier 

i :entier

Début

Ecrire’’ donner un nombre’’

Lire x

Pour i ←x+1, x+10,1 faire

Ecrire  i

Fin pour

Fin

Exercice 4 :

Ecrire un algorithme qui demande d'entrer un nombre de départ et ensuite le programme affiche sa table de multiplication. Par exemple si l'utilisateur entre 7, le programme affiche:

7 * 1 = 7

7 * 2 = 14

7 * 10 = 70

Solution :

Algo table multiplication

Var

x :entier 

i :entier

r :entier

Début

Ecrire’’ donner un nombre’’

Lire x

Ecrire ‘’table de‘’,x,’’ :’’

                Pour i ←1,10,1 faire

                                R←x*i

                                Ecrire x ’’* ‘’,I,’’=’’,r

                Fin pour

Fin

Exercice 5 :

Ecrire un algorithme qui demande d'entrer un nombre de départ et qui calcule la somme des entiers jusqu'à un se nbre par exemple si l'utilisateur entre le nombre 5 le programme doit calculer 1 + 2 + 3 + 4 + 5 = 15

On souhaite afficher que le résultat, pas la méthode de calcul.

Solution :

Algo somme

Var

x :entier 

i :entier

s :entier

Début

Ecrire’’ donner un nombre’’

Lire x

S←0

Pour iß1, x,1 faire

                S←s+i

Fin pour

Ecrire ‘’la somme est :’’s

Fin

Exercice 6 :

Ecrire un algorithme qui demande d’entrer un nombre de départ et que le programme calcule la factorielle de se nombre. Par exemple l’utilisateur entre la valeur 8, note 8 !

Vaut

8 * 7 * 6 * 5 * 4 * 3 * 2 * 1 = 40 320

Solution :

Algo factorielle

Var

x :entier 

i :entier

f :entier

Début

Répéter

Ecrire’’ donner un nombre’’

Lire x

Jusqu’à x>=0

Si x=o alors

                f←1

Si non

f←1

Pour i←1, x,1 faire

                                                f←f*i

Fin pour

                Fin si

Ecrire x ,’’ !=’’,f

Fin

Exercice 7 :

Ecrire un algorithme qui demande successivement 20nombre a l’utilisateur, et qui lui disent en suit quel était le plus grand nombre parmi ces 20 nombres.

Solution :

Algo le plus grand nombre saisi

Var

x :entier 

i :entier

g :entier

Début

g←0

Pour i←1,20,1 faire

Ecrire ’’donner le nombre’’ i

Lire x

Si i=1 alors

                g←x

Fin si

si x>g alors

g←x

Fin si

Fin pour

Ecrire ‘’le plus grand nombre saisie est’’ ,g

Fin

Files